数据库表目录
序号 | 表名 | 说明
1 | PMS_bas_Behavior | 行为码表
2 | PMS_bas_BookTemplate | 任务模板表
3 | PMS_bas_StationIDRelated | 站点关联表
4 | PMS_bas_StepBookTemplate | 步骤模板表
5 | PMS_bas_Warehouse | 简易库位管理
6 | PMS_bas_WarehouseType | 库位类型配置
7 | PMS_his_HistoryOrderData | 历史订单数据
8 | PMS_his_HistoryStepBook | 历史步骤簿数据
9 | PMS_his_HistoryTaskBook | 历史任务簿数据
10 | PMS_mid_CarriersInfo | 小车实时数据表
11 | PMS_mid_OrderData | 订单数据表
12 | PMS_mid_StepBook | 步骤簿数据表
13 | PMS_mid_TaskBook | 任务簿数据表
14 | PMS_sys_DBVersion | 数据库版本
15 | PMS_sys_FormColumnSetting | 界面显示列配置表
16 | PMS_sys_Language | 语言设置表
17 | PMS_sys_LanguageKey | 语言设置表键
18 | PMS_sys_MenuSetting | 显示菜单配置表
19 | PMS_sys_OperationLog | 界面操作日志表
20 | PMS_sys_PermissionSetting | 权限设置表
21 | PMS_sys_UserInfo | 用户配置表


PMS_bas_Behavior

PMS_bas_Behavior （行为码表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | Behavior | 行为码 | int | 4 | × | √ | × | NULL
2 | Value | 含义 | nvarchar | 100 | × | × | × | ('')
3 | Type | 行为码类型 | int | 4 | × | × | × | ((0))
4 | Standard | 是否是标准操作码 非标代表现场定制 无通用性 | bit | 1 | × | × | × | ((1))
5 | DisplayMessage | 执行行为码时显示信息 | nvarchar | 100 | × | × | × | ('')
6 | remark | 备注 | nvarchar | 100 | × | × | × | ('')
7 | Reserved1 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
8 | Reserved2 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
9 | Reserved3 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_bas_BookTemplate

PMS_bas_BookTemplate （任务模板表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
2 | TemplateID | 模板ID | nvarchar | 100 | × | √ | × | NULL
3 | StepID | 步骤 | int | 4 | × | √ | × | NULL
4 | Behavior | 模板行为码 | int | 4 | × | × | × | NULL
5 | NextSpecialStep | 特殊下一步 | int | 4 | × | × | × | ((0))
6 | NextDefaultStep | 默认下一步 | int | 4 | × | × | × | ((0))
8 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')


PMS_bas_StationIDRelated

PMS_bas_StationIDRelated （站点关联表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | StationID | 活动站点 | int | 4 | × | √ | × | NULL
2 | RelatedStationID1 | 关联 活动站点1 | int | 4 | × | × | × | ((0))
3 | RelatedVertex1 | 关联导航点1 | int | 4 | × | × | × | ((0))
4 | RelatedStationID2 | 关联 活动站点2 | int | 4 | × | × | × | ((0))
5 | RelatedVertex2 | 关联导航点2 | int | 4 | × | × | × | ((0))
6 | RelatedStationID3 | 关联 活动站点3 | int | 4 | × | × | × | ((0))
7 | RelatedVertex3 | 关联导航点3 | int | 4 | × | × | × | ((0))
8 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')
9 | Reserved1 | 保留字段，备用 | nvarchar | 100 | × | × | × | ('')
10 | Reserved2 | 保留字段，备用 | nvarchar | 100 | × | × | × | ('')
11 | Reserved3 | 保留字段，备用 | nvarchar | 100 | × | × | × | ('')


PMS_bas_StepBookTemplate

PMS_bas_StepBookTemplate （步骤模板表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
2 | TemplateID | 任务模板ID | nvarchar | 100 | × | √ | × | NULL
3 | StepID | 步骤ID | int | 4 | × | √ | × | ((0))
4 | Behavior | 行为码 | int | 4 | × | × | × | ((0))
5 | AgvBehavior | AGV动作 行为码 | int | 4 | × | × | × | ((0))
6 | NextDefaultStep | 默认下一步骤 | int | 4 | × | × | × | ((0))
7 | NextSpecialStep | 特殊下一步骤 | int | 4 | × | × | × | ((0))
10 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')


PMS_bas_Warehouse

PMS_bas_Warehouse （简易库位管理）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | WareHouseID | 库位号 | nvarchar | 40 | × | √ | × | NULL
2 | WareHouseName | 库位名称 | nvarchar | 100 | × | × | × | ('')
3 | WareHouseStatus | 库位状态 | nvarchar | 20 | × | × | × | (N'UnKnown')
4 | WareHouseType | 库位类型 | nvarchar | 100 | × | × | × | ('')
5 | StationID | 节点号 | int | 4 | × | × | × | ((0))
6 | RegionID | 区域号 | nvarchar | 40 | × | × | × | ('')
7 | RegionSeq | 区域内 库位的顺序 | int | 4 | × | × | × | ((0))
8 | MaterialID | 物料号 | nvarchar | 100 | × | × | × | ('')
9 | RackID | 料架号 | nvarchar | 100 | × | × | × | ('')
10 | ProductRegion | 生产区 | nvarchar | 100 | × | × | × | ('')
11 | UpdateTime | 更新时间 | datetime | 8 | × | × | × | ('1899-01-01')


PMS_bas_WarehouseType

PMS_bas_WarehouseType （库位类型配置）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
2 | WarehouseType | 库位类型 | nvarchar | 100 | × | √ | × | NULL
3 | StepBookTemplateID | 任务模板ID | nvarchar | 100 | × | √ | × | ('')
4 | BookTemplateBehavior | 关联的大模板 行为码 | int | 4 | × | √ | × | ((0))
5 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')
6 | Reserved1 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
7 | Reserved2 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
8 | Reserved3 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_his_HistoryOrderData

PMS_his_HistoryOrderData （历史订单数据）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | OrderGuid | Guid 唯一标识 | uniqueidentifier | 16 | × | √ | × | NULL
2 | OrderID | 订单ID 唯一标识 | nvarchar | 100 | × | × | × | NULL
3 | ParentOrderID | 父订单ID | nvarchar | 100 | × | × | × | ('')
4 | PrevOrderID | 前置订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
5 | NextOrderID | 后续订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
6 | OrderState | 订单状态 | int | 4 | × | × | × | ((0))
7 | OrderType | 订单类型 | int | 4 | × | × | × | ((0))
8 | OrderPriority | 订单优先级 | int | 4 | × | × | × | ((1))
9 | OrderCanCancel | 订单是否可取消 | bit | 1 | × | × | × | ((0))
10 | OrderCanceled | 订单取消状态 | bit | 1 | × | × | × | ((0))
11 | TaskID | 根据订单ID生成的任务ID | nvarchar | 100 | × | × | × | ('')
12 | BookID | 当前执行的任务簿ID | nvarchar | 100 | × | × | × | ('')
13 | BookState | 当前执行的任务簿状态 | int | 4 | × | × | × | ((0))
14 | Carrier | AgvID | int | 4 | × | × | × | ((0))
15 | Token | 小车任务凭证 | int | 4 | × | × | × | ((0))
16 | CarrierType | 小车类型 | int | 4 | × | × | × | ((0))
17 | CarrierState | 小车状态 | int | 4 | × | × | × | ((0))
18 | CarrierWarningBit | 小车报警位 | int | 4 | × | × | × | ((0))
19 | PosArrLength | 任务点数量 | int | 4 | × | × | × | ((0))
20 | PosArr | 任务点队列 | nvarchar | 1000 | × | × | × | ('')
21 | BookTemplateID | 任务模板ID | nvarchar | 100 | × | × | × | ('')
22 | CreateTime | 创建时间 | datetime | 8 | × | × | × | ('1899-01-01')
23 | CalledTime | 叫料时间 | datetime | 8 | × | × | × | ('1899-01-01')
24 | StartTime | 开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
25 | EndTime | 结束时间 | datetime | 8 | × | × | × | ('1899-01-01')
26 | ErrorCode | 错误码 | int | 4 | × | × | × | ((0))
27 | DisplayMessage | 显示数据 | nvarchar | 100 | × | × | × | ('')
28 | OtherOrderData | 订单额外数据 | nvarchar | 2000 | × | × | × | ('')
29 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')
30 | Reserved1 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
31 | Reserved2 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
32 | Reserved3 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_his_HistoryStepBook

PMS_his_HistoryStepBook （历史步骤簿数据）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | StepGuid | Guid 唯一标识 | uniqueidentifier | 16 | × | √ | × | NULL
2 | BookGuid | 对应任务 簿的Guid ,在TaskBook中唯一,此表中不唯一 | uniqueidentifier | 16 | × | × | × | NULL
3 | BookID | 任务簿ID | nvarchar | 100 | × | × | × | NULL
4 | OrderID | 订单号 | nvarchar | 100 | × | × | × | NULL
5 | StepID | 步骤ID | int | 4 | × | × | × | NULL
6 | StepCanRun | 步骤是否可以执行 | bit | 1 | × | × | × | ((1))
7 | HasNextStep | 是否有下一步 | bit | 1 | × | × | × | ((0))
8 | NextStepID | 下一步step的值 | int | 4 | × | × | × | ((0))
9 | NextDefaultStepID | 默认下一步骤 | int | 4 | × | × | × | ((0))
10 | NextSpcialStepID | 下一步特殊step的stepID值 | int | 4 | × | × | × | ((0))
11 | CarrierStepState | 小车步骤状态 | int | 4 | × | × | × | ((0))
12 | SystemStepState | 系统步骤状态 | int | 4 | × | × | × | ((0))
13 | UserStepState | 用户步骤状态 | int | 4 | × | × | × | ((0))
14 | WareHouseID | 任务对应库位号 | nvarchar | 100 | × | × | × | ('')
15 | StationID | 步骤任务对应的活动站点 | int | 4 | × | × | × | ((0))
16 | Vertex | 步骤任务对应的导航点 | int | 4 | × | × | × | ((0))
17 | AgvBehavior | AGV行为码，地图中画的行为码 | int | 4 | × | × | × | ((0))
18 | Behavior | 行为码，系统规划任务的行为码 | int | 4 | × | × | × | ((0))
19 | CreateTime | 创建时间 | datetime | 8 | × | × | × | ('1899-01-01')
20 | StartTime | 步骤执行开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
21 | FinishTime | 步骤执行完成时间 | datetime | 8 | × | × | × | ('1899-01-01')
22 | SendSignalSuccess | 信号是否发送成功 | bit | 1 | × | × | × | ((1))
23 | SendSignalFailTimes | 信号发送失败 | int | 4 | × | × | × | ((0))
24 | LastSendSignalTime | 上次发送信号的时间 | datetime | 8 | × | × | × | ('1899-01-01')


PMS_his_HistoryTaskBook

PMS_his_HistoryTaskBook （历史任务簿数据）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | BookGuid | Guid 唯一标识 | uniqueidentifier | 16 | × | √ | × | NULL
2 | TaskID | 任务ID | nvarchar | 100 | × | × | × | NULL
3 | OrderID | 订单ID | nvarchar | 100 | × | × | × | NULL
4 | ParentOrderID | 父订单ID | nvarchar | 100 | × | × | × | ('')
5 | PrevOrderID | 前置订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
6 | NextOrderID | 后续订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
7 | BookID | 任务簿ID | nvarchar | 100 | × | × | × | ('')
8 | BookCanRun | 任务簿是否可执行 | bit | 1 | × | × | × | ((1))
9 | NextBookID | 下一步 实际执行 BookID | nvarchar | 100 | × | × | × | ('')
10 | NextSpecialBookID | 特殊情况下 下一步ID | nvarchar | 100 | × | × | × | ('')
11 | NextDefaultBookID | 默认下一步ID | nvarchar | 100 | × | × | × | ('')
12 | BookTemplateBehavior | 任务模板 行为码 | int | 4 | × | × | × | ((0))
13 | BookType | 任务簿类型 | int | 4 | × | × | × | ((0))
14 | BookState | 任务簿状态 | int | 4 | × | × | × | ((0))
15 | HasNextBook | 是否有下一个任务簿 | bit | 1 | × | × | × | ((0))
16 | Carrier | agvID值 | int | 4 | × | × | × | ((0))
17 | CarrierType | AGV类型 | int | 4 | × | × | × | ((0))
18 | Token | 小车任务凭证 | int | 4 | × | × | × | ((0))
19 | Priority | 任务优先级 | int | 4 | × | × | × | ((0))
20 | WareHouse | 库位号 | nvarchar | 100 | × | × | × | ('')
21 | StationID | 活动站点 | int | 4 | × | × | × | ((0))
22 | CreateTime | 创建时间 | datetime | 8 | × | × | × | ('1899-01-01')
23 | CalledTime | 叫料时间 | datetime | 8 | × | × | × | ('1899-01-01')
24 | StartTime | 任务开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
25 | EndTime | 任务结束时间 | datetime | 8 | × | × | × | ('1899-01-01')
26 | SettingTime | 设定完成时间 | int | 4 | × | × | × | ((0))
27 | StepID | 当前执行步骤簿stepID | int | 4 | × | × | × | ((0))
28 | ErrorCode | 错误码 | int | 4 | × | × | × | ((0))
29 | Remark | 备注说明 | nvarchar | 100 | × | × | × | ('')
30 | Reserved1 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
31 | Reserved2 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
32 | Reserved3 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_mid_CarriersInfo

PMS_mid_CarriersInfo （小车实时数据表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | CarrierIndex | agvid | int | 4 | × | √ | × | NULL
2 | Status | 0：空闲，1：配送中，3：完成 | int | 4 | × | × | × | ((0))
3 | OrderID | 任务单号 | nvarchar | 100 | × | × | × | ('')
4 | Type | AGV类型 | int | 4 | × | × | × | ((0))
5 | InSystem | 是否在系统中 | bit | 1 | × | × | × | ((65535))
6 | WarningBit | 报警位 | int | 4 | × | × | × | ((0))
7 | BatteryLevel | 电池电量 | int | 4 | × | × | × | ((0))
8 | Online | 小车是否在线 | bit | 1 | × | × | × | ((0))
9 | MovementState | 行驶状态（0：未知，1：行驶中，2：停止中，3：管制中，4：暂停中） | int | 4 | × | × | × | ((0))
10 | MovementX | 小车所在位置的X坐标 | float | 8 | × | × | × | ((0))
11 | MovementY | 小车所在位置的Y坐标 | float | 8 | × | × | × | ((0))
12 | MovementAttitude | 小车的姿态（方向） | float | 8 | × | × | × | ((0))
13 | GraphVertex | 系统任务状态（0：空闲，1：配送中，3：完成，11：错误） | int | 4 | × | × | × | ((0))
14 | SystemOrderState | 当前导航点 | int | 4 | × | × | × | ((0))
15 | SystemOrderSource | 系统命令源（0：无任务源，1：待命站点，2：活动站点） | int | 4 | × | × | × | ((0))
16 | SystemOrderFault | 系统任务错误码（0：无，1：错误的路径点，2：错误的站点，3：错误的行为，4：规划错误） | int | 4 | × | × | × | ((0))
17 | TrafficBlocked | 是否被管制 | bit | 1 | × | × | × | ((0))
18 | TrafficBlockingType | 管制类型（0：无，1：小车，2：变量） | int | 4 | × | × | × | ((0))
19 | UpDateTime | 数据更新时间 | datetime | 8 | × | × | × | ('1899-01-01')


PMS_mid_OrderData

PMS_mid_OrderData （订单数据表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | OrderGuid | Guid 唯一标识 | uniqueidentifier | 16 | × | √ | × | NULL
2 | OrderID | 订单ID 唯一标识 | nvarchar | 100 | × | × | × | NULL
3 | ParentOrderID | 父订单ID | nvarchar | 100 | × | × | × | ('')
4 | PrevOrderID | 前置订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
5 | NextOrderID | 后续订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
6 | OrderState | 订单状态 | int | 4 | × | × | × | ((0))
7 | OrderType | 订单类型 | int | 4 | × | × | × | ((0))
8 | OrderPriority | 订单优先级 | int | 4 | × | × | × | ((1))
9 | OrderCanCancel | 订单是否可取消 | bit | 1 | × | × | × | ((0))
10 | OrderCanceled | 订单取消状态 | bit | 1 | × | × | × | ((0))
11 | TaskID | 根据订单ID生成的任务ID | nvarchar | 100 | × | × | × | ('')
12 | BookID | 当前执行的任务簿ID | nvarchar | 100 | × | × | × | ('')
13 | BookState | 当前执行的任务簿状态 | int | 4 | × | × | × | ((0))
14 | Carrier | AgvID | int | 4 | × | × | × | ((0))
15 | Token | 小车任务凭证 | int | 4 | × | × | × | ((0))
16 | CarrierType | 小车类型 | int | 4 | × | × | × | ((0))
17 | CarrierState | 小车状态 | int | 4 | × | × | × | ((0))
18 | CarrierWarningBit | 小车报警位 | int | 4 | × | × | × | ((0))
19 | PosArrLength | 任务点数量 | int | 4 | × | × | × | ((0))
20 | PosArr | 任务点队列 | nvarchar | 1000 | × | × | × | ('')
21 | BookTemplateID | 任务模板ID | nvarchar | 100 | × | × | × | ('')
22 | CreateTime | 创建时间 | datetime | 8 | × | × | × | ('1899-01-01')
23 | CalledTime | 叫料时间 | datetime | 8 | × | × | × | ('1899-01-01')
24 | StartTime | 开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
25 | EndTime | 结束时间 | datetime | 8 | × | × | × | ('1899-01-01')
26 | ErrorCode | 错误码 | int | 4 | × | × | × | ((0))
27 | DisplayMessage | 显示数据 | nvarchar | 100 | × | × | × | ('')
28 | OtherOrderData | 订单额外数据 | nvarchar | 2000 | × | × | × | ('')
29 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')
30 | Reserved1 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
31 | Reserved2 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
32 | Reserved3 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_mid_StepBook

PMS_mid_StepBook （步骤簿数据表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | StepGuid | Guid 唯一标识 | uniqueidentifier | 16 | × | √ | × | NULL
2 | BookGuid | 对应任务 簿的Guid ,在TaskBook中唯一,此表中不唯一 | uniqueidentifier | 16 | × | × | × | NULL
3 | BookID | 任务簿ID | nvarchar | 100 | × | × | × | NULL
4 | OrderID | 订单号 | nvarchar | 100 | × | × | × | NULL
5 | StepID | 步骤ID | int | 4 | × | × | × | NULL
6 | StepCanRun | 步骤是否可以执行 | bit | 1 | × | × | × | ((1))
7 | HasNextStep | 是否有下一步 | bit | 1 | × | × | × | ((0))
8 | NextStepID | 下一步step的值 | int | 4 | × | × | × | ((0))
9 | NextDefaultStepID | 默认下一步骤 | int | 4 | × | × | × | ((0))
10 | NextSpcialStepID | 下一步特殊step的stepID值 | int | 4 | × | × | × | ((0))
11 | CarrierStepState | 小车步骤状态 | int | 4 | × | × | × | ((0))
12 | SystemStepState | 系统步骤状态 | int | 4 | × | × | × | ((0))
13 | UserStepState | 用户步骤状态 | int | 4 | × | × | × | ((0))
14 | WareHouseID | 任务对应库位号 | nvarchar | 100 | × | × | × | ('')
15 | StationID | 步骤任务对应的活动站点 | int | 4 | × | × | × | ((0))
16 | Vertex | 步骤任务对应的导航点 | int | 4 | × | × | × | ((0))
17 | AgvBehavior | AGV行为码，地图中画的行为码 | int | 4 | × | × | × | ((0))
18 | Behavior | 行为码，系统规划任务的行为码 | int | 4 | × | × | × | ((0))
19 | CreateTime | 创建时间 | datetime | 8 | × | × | × | ('1899-01-01')
20 | StartTime | 步骤执行开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
21 | FinishTime | 步骤执行完成时间 | datetime | 8 | × | × | × | ('1899-01-01')
22 | SendSignalSuccess | 信号是否发送成功 | bit | 1 | × | × | × | ((1))
23 | SendSignalFailTimes | 信号发送失败 | int | 4 | × | × | × | ((0))
24 | LastSendSignalTime | 上次发送信号的时间 | datetime | 8 | × | × | × | ('1899-01-01')


PMS_mid_TaskBook

PMS_mid_TaskBook （任务簿数据表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | BookGuid | Guid 唯一标识 | uniqueidentifier | 16 | × | √ | × | NULL
2 | TaskID | 任务ID | nvarchar | 100 | × | × | × | NULL
3 | OrderID | 订单ID | nvarchar | 100 | × | × | × | NULL
4 | ParentOrderID | 父订单ID | nvarchar | 100 | × | × | × | ('')
5 | PrevOrderID | 前置订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
6 | NextOrderID | 后续订单ID 做任务续接时使用 | nvarchar | 100 | × | × | × | ('')
7 | BookID | 任务簿ID | nvarchar | 100 | × | × | × | ('')
8 | BookCanRun | 任务簿是否可执行 | bit | 1 | × | × | × | ((1))
9 | NextBookID | 下一步 实际执行 BookID | nvarchar | 100 | × | × | × | ('')
10 | NextSpecialBookID | 特殊情况下 下一步ID | nvarchar | 100 | × | × | × | ('')
11 | NextDefaultBookID | 默认下一步ID | nvarchar | 100 | × | × | × | ('')
12 | BookTemplateBehavior | 任务模板 行为码 | int | 4 | × | × | × | ((0))
13 | BookType | 任务簿类型 | int | 4 | × | × | × | ((0))
14 | BookState | 任务簿状态 | int | 4 | × | × | × | ((0))
15 | HasNextBook | 是否有下一个任务簿 | bit | 1 | × | × | × | ((0))
16 | Carrier | agvID值 | int | 4 | × | × | × | ((0))
17 | CarrierType | AGV类型 | int | 4 | × | × | × | ((0))
18 | Token | 小车任务凭证 | int | 4 | × | × | × | ((0))
19 | Priority | 任务优先级 | int | 4 | × | × | × | ((0))
20 | WareHouse | 库位号 | nvarchar | 100 | × | × | × | ('')
21 | StationID | 活动站点 | int | 4 | × | × | × | ((0))
22 | CreateTime | 创建时间 | datetime | 8 | × | × | × | ('1899-01-01')
23 | CalledTime | 叫料时间 | datetime | 8 | × | × | × | ('1899-01-01')
24 | StartTime | 任务开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
25 | EndTime | 任务结束时间 | datetime | 8 | × | × | × | ('1899-01-01')
26 | SettingTime | 设定完成时间 | int | 4 | × | × | × | ((0))
27 | StepID | 当前执行步骤簿stepID | int | 4 | × | × | × | ((0))
28 | ErrorCode | 错误码 | int | 4 | × | × | × | ((0))
29 | Remark | 备注说明 | nvarchar | 100 | × | × | × | ('')
30 | Reserved1 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
31 | Reserved2 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')
32 | Reserved3 | 保留字段，以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_sys_DBVersion

PMS_sys_DBVersion （数据库版本）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | Version | 数据库版本 | nvarchar | 100 | × | √ | × | NULL
2 | ProVer | 软件版本 | nvarchar | 100 | × | × | × | NULL
3 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')


PMS_sys_FormColumnSetting

PMS_sys_FormColumnSetting （界面显示列配置表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | FormName | 界面名称 | nvarchar | 100 | × | √ | × | NULL
2 | DBColumnName | 数据表字段名 | nvarchar | 100 | × | √ | × | NULL
3 | ShowColumnName | 数据库表字段显示名 | nvarchar | 100 | × | × | × | ('')
4 | IsShow | 是否显示 | bit | 1 | × | × | × | ((0))
5 | Sort | 显示顺序 | int | 4 | × | × | × | ((0))


PMS_sys_Language

PMS_sys_Language （语言设置表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
2 | Language | 语言 | nvarchar | 100 | × | √ | × | NULL
3 | Keyword | 关键字 | nvarchar | 100 | × | √ | × | ('')
4 | Displayword | 显示语言 | nvarchar | 100 | × | × | × | ('')
5 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')
6 | Reserved1 | 保留 以后备用 | nvarchar | 100 | × | × | × | ('')
7 | Reserved2 | 保留 以后备用 | nvarchar | 100 | × | × | × | ('')
8 | Reserved3 | 保留 以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_sys_LanguageKey

PMS_sys_LanguageKey （语言设置表键）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | Keyword | 语言设置 主键 | nvarchar | 100 | × | √ | × | NULL


PMS_sys_MenuSetting

PMS_sys_MenuSetting （显示菜单配置表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | MenuName | 菜单名称 | nvarchar | 100 | × | √ | × | NULL
2 | DisplayMenuName | 菜单显示名称 | nvarchar | 100 | × | × | × | ('')
3 | ModuleName | 父菜单名 | nvarchar | 100 | × | × | × | ('')
4 | IsShow | 是否显示 | bit | 1 | × | × | × | ((0))
5 | ParentMenuSort | 父菜单排序 | int | 4 | × | × | × | ((0))
6 | ChildMenuSort | 子菜单排序 | int | 4 | × | × | × | ((0))


PMS_sys_OperationLog

PMS_sys_OperationLog （界面操作日志表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | ID | GUID 唯一建 | uniqueidentifier | 16 | × | √ | × | (newid())
2 | UserID | 用户ID | nvarchar | 100 | × | × | × | NULL
3 | IP | 电脑IIP地址 | nvarchar | 100 | × | × | × | ('')
4 | MAC | mac地址 | nvarchar | 100 | × | × | × | ('')
5 | LogLevel | 日志等级 | int | 4 | × | × | × | ((0))
6 | Type | 操作类型 | nvarchar | 100 | × | × | × | ('')
7 | Module | 操作的模块 | nvarchar | 100 | × | × | × | ('')
8 | BusinessName | 操作业务名称 | nvarchar | 100 | × | × | × | ('')
9 | OperateTime | 操作时间 | datetime | 8 | × | × | × | ('1899-01-01')
10 | Information | 操作详情 | nvarchar | -1 | × | × | × | ('')


PMS_sys_PermissionSetting

PMS_sys_PermissionSetting （权限设置表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
2 | Permission | 权限 主键 | nvarchar | 40 | × | √ | × | ('')
3 | CNFormName | 中文界面名称 | nvarchar | 100 | × | √ | × | ('')
4 | ENFormName | 英文界面名称 | nvarchar | 100 | × | × | × | ('')
5 | PermissionLevel | 权限等级 | int | 4 | × | × | × | ((0))
6 | AuditPermissionLevel | 审核权限等级 | nvarchar | 100 | × | × | × | ('')
7 | Remark | 备注 | nvarchar | 100 | × | × | × | ('')
8 | Reserved1 | 保留字段,以后备用 | nvarchar | 100 | × | × | × | ('')
9 | Reserved2 | 保留字段,以后备用 | nvarchar | 100 | × | × | × | ('')
10 | Reserved3 | 保留字段,以后备用 | nvarchar | 100 | × | × | × | ('')


PMS_sys_UserInfo

PMS_sys_UserInfo （用户配置表）
序号 | 字段 | 说明 | 数据类型 | 长度 | 自增 | 主键 | 允许空 | 默认值
1 | AutoID | 自增ID | int | 4 | √ | √ | × | NULL
2 | UserName | 用户名 | nvarchar | 100 | × | × | × | ('')
3 | UserID | 用户ID | nvarchar | 100 | × | × | × | NULL
4 | Passwd | 密码 | nvarchar | 100 | × | × | × | NULL
5 | AuditPassword | 审核密码 | nvarchar | 100 | × | × | × | ('')
6 | Permission | 权限 | nvarchar | 100 | × | × | × | NULL
7 | StartTime | 授权开始时间 | datetime | 8 | × | × | × | ('1899-01-01')
8 | EndTime | 授权结束时间 | datetime | 8 | × | × | × | ('1899-01-01')
9 | ModifyUser | 修改用户 | nvarchar | 100 | × | × | × | ('')
10 | ModifyTime | 修改时间 | datetime | 8 | × | × | × | ('1899-01-01')
11 | Active | 是否启用 | bit | 1 | × | × | × | ((1))